Michal Čihař - Updated phpMyAdmin packages

Updated phpMyAdmin packages

Finally, I've found some time to update phpMyAdmin packages in Debian to 3.5 series. For long it was not possible due to licensing reasons, but recently this issue was resolved upstream by using jqPlot instead of Highcharts.

While packaging new version, I've also replaced all embedded libraries to use corresponding packages from Debian. I've done some testing and everything seems to work fine, but still this frightens me as some versions are slightly different than upstream.

Anyway new version is available in experimental for now. Ubuntu users can get it from phpMyAdmin PPA.

Comments

Harald Nehring wrote on Jan. 9, 2013, 6:20 p.m.

Hi Michal, thanks for keeping phpMyAdmin up-to-date for Lucid users. Unfortunately I can't upgrade to 3.5 on my box due to dependencies on libjs-jquery-cookie, -jquery-mousewheel, -jquery-event-drag, -jquery-tablesorter and -codemirror. These packages can't be found in my package sources - any recommendation where to get them from for Lucid?
Thanks, Harald

Moritz Heiber wrote on Jan. 9, 2013, 7:16 p.m.

Hey Michal, thank you for your continued support and engagement! Your Ubuntu PPA for phpmyadmin is much appreciated.

However, the latest version seems to have a version mismatch of sort. When trying to install the latest phpmyadmin under Ubuntu 12.04.1 LTS I get the following:

# apt-get install phpmyadmin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
phpmyadmin : Depends: libjs-codemirror but it is not installable
E: Unable to correct problems, you have held broken packages.

It seems as though this particular package is only available for users of Ubuntu 12.10 and beyond :/

wrote on Jan. 9, 2013, 7:39 p.m.

Hmm, looks like I will have to add some extra packages :-(.

wrote on Jan. 9, 2013, 8:13 p.m.

I've just uploaded missing packages to PPA, in case I've missed anything, please let me know.

Harald Nehring wrote on Jan. 10, 2013, 9:34 p.m.

Thanks, Michal - libjs-codemirror still broken for Lucid.

wrote on Jan. 10, 2013, 10:15 p.m.

It would need even more backporting, so probably Lucid packages will not be usable...

Guillaume MESSONNIER wrote on Jan. 11, 2013, 7:19 p.m.

Hi !

Thanks for your work. I've just try to install phpmyadmin 3.5 version on Ubuntu Lucid and i've the same problem than Moritz Heiber :
"libjs-codemirror but it is not installable".

Is-it possible to backport this lib on lucid ?

Thanks.

wrote on Jan. 12, 2013, 10:43 a.m.

Definitely it is possible, but I currently don't have time for that...

Guillaume MESSONNIER wrote on Jan. 12, 2013, 5:44 p.m.

Snif :-(

Luciano wrote on Jan. 26, 2013, 6:35 a.m.

I would really appreciate the migration for lucid too, as all my prod servers are using it (and my notebook too). thanks

da.vinci wrote on Jan. 29, 2013, 9:04 a.m.

Great lucid is broken.

But perhaps you could (for lucid only) rollback the pakage to the previous version

wrote on Jan. 29, 2013, 9:35 a.m.

Updated packages which should work on Lucid as well are just building, I will publish a blog post when they are ready.

New Comment

You can not add new comments to old blog posts.